SEO-G Installed but not working?

Home Forums Web Design and Development Contribution Garage SEO-G Installed but not working?

This topic contains 22 replies, has 0 voices, and was last updated by  RocksIT 10 years, 10 months ago.

  • Author
    Posts
  • #23859

    RocksIT
    Participant

    Hi, I just installed the SEO-G Url re-write contribution.. basicly because I didn’t want to shell out $50 for Ultimate 4.0, & have read some good reviews of the flexability of G… well i modded the files.. & i believe i have everything installed right..

    but none of my URLs are being re-written… any ideas on what step I missed? or? I don’t get any error messages, & am pretty used to installed contribs correctly…

    my website is http://PleasurePlayToys.com

    thanks for any help!

    Rusty

  • #107181

    ezstoresites
    Participant

    Did you set your .htacess file correctly? That would be the first place to look if the rewrites aren’t working.

    Your link doesn’t work above 500 error or maybe I was hitting it while you were working on it.

    Mike

  • #107182

    RocksIT
    Participant

    yes , I was working on it last night then gave up.. yes i think it must have something to do w/ the .htaccess files.. but i’m not sure what…

    the link is back up now.. you don’t happen to have this installed & have a correct .htaccess file i could look at do you?

    Thanks,
    Rusty

    http://PleasurePlayToys.com

  • #107183

    Satish
    Participant

    @rocksit wrote:

    yes , I was working on it last night then gave up.. yes i think it must have something to do w/ the .htaccess files.. but i’m not sure what…

    the link is back up now.. you don’t happen to have this installed & have a correct .htaccess file i could look at do you?

    Thanks,
    Rusty

    http://PleasurePlayToys.com

    Did You set the flag for SEO to true.
    I do not see it converting osc url to seo tyoe html url.

    DId YOu place the proper root.php file.

    Satish

  • #107184

    RocksIT
    Participant

    Thanks Satish, yes I have the flag set to true for SEO-G in admin

    also i believe i have the root.php file in the right place….

    the odd thing is i get no error messages either..

  • #107185

    ezstoresites
    Participant

    Did you modify the root.php file to reflect the application_top file? The root file by default won’t work. It needs to be modified as outlined in the install directions.

    Mike

  • #107186

    RocksIT
    Participant

    Hi mike i just double checked.. yes it is modified & includes the application_top section… I’m going back now step by step to see if theirs anything I missed..

    One thing I see.. in configuration it says

    Goto your osC Admin->Configuration->My Store->Use search Engine Safe URLs. Make sure the switch is set to false.

    this version of CRE loaded doesn’t have that option under “My Store”…

    where do i find that to turn it off??

  • #107187

    RocksIT
    Participant

    i just checked w/ phpmyadmin all the redirect names are written in the db… but don’t show up on the site..
    or in admin: G-Redirects or G-Reports

    also i went to configuration:Page cache settings: & turned “Disable URL Parameters?” to true..

    wasn’t sure if this is where I need to do it..

    there’s got to be something simple I’m missing

  • #107188

    ezstoresites
    Participant

    Are you sure your host has mod rewrite enabled? If your .htacess file is directing the rewrite and you’re not seeing it then I’d investigate whether your host has it enabled. Here is what ours looks like and our store is in the root.

    # $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $
    #
    # This is used with Apache WebServers
    #
    # For this to work, you must include the parameter ‘Options’ to
    # the AllowOverride configuration
    #
    # Example:
    #
    #
    # AllowOverride Options
    #
    #
    # ‘All’ with also work. (This configuration is in the
    # apache/conf/httpd.conf file)

    # The following makes adjustments to the SSL protocol for Internet
    # Explorer browsers
    # DirectoryIndex index.htm

    SetEnvIf User-Agent “.*MSIE.*”
    nokeepalive ssl-unclean-shutdown
    downgrade-1.0 force-response-1.0

    # Fix certain PHP values
    # (commented out by default to prevent errors occuring on certain
    # servers)

    php_value session.use_trans_sid 0
    php_value register_globals 1

    #-MS- SEO-G Added
    Options +FollowSymLinks
    RewriteEngine On
    # Next line must be changed to match your osCommerce folder – the relative path
    RewriteBase /
    RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING}
    #-MS- SEO-G Added EOM

    The only other thing that comes to mind is you didn’t change the extension in seo_g configuration to something other than html did you? You can change it, for example to htm, but you need to change it in your htaccess file also. They must match.

    Mike

  • #107189

    Satish
    Participant

    @ezstoresites wrote:

    Are you sure your host has mod rewrite enabled? If your .htacess file is directing the rewrite and you’re not seeing it then I’d investigate whether your host has it enabled. Here is what ours looks like and our store is in the root.

    # $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $
    #
    # This is used with Apache WebServers
    #
    # For this to work, you must include the parameter ‘Options’ to
    # the AllowOverride configuration
    #
    # Example:
    #
    #
    # AllowOverride Options
    #
    #
    # ‘All’ with also work. (This configuration is in the
    # apache/conf/httpd.conf file)

    # The following makes adjustments to the SSL protocol for Internet
    # Explorer browsers
    # DirectoryIndex index.htm

    SetEnvIf User-Agent “.*MSIE.*”
    nokeepalive ssl-unclean-shutdown
    downgrade-1.0 force-response-1.0

    # Fix certain PHP values
    # (commented out by default to prevent errors occuring on certain
    # servers)

    php_value session.use_trans_sid 0
    php_value register_globals 1

    #-MS- SEO-G Added
    Options +FollowSymLinks
    RewriteEngine On
    # Next line must be changed to match your osCommerce folder – the relative path
    RewriteBase /
    RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING}
    #-MS- SEO-G Added EOM

    The only other thing that comes to mind is you didn’t change the extension in seo_g configuration to something other than html did you? You can change it, for example to htm, but you need to change it in your htaccess file also. They must match.

    Mike

    chek the following:
    1)Is rewrite rule working.
    2)root.php modified as per instruction ini the code file itself.
    3).htaccess file in place.
    4)Redirect set to false.

    post Your status on this points.

    Satish

  • #107190

    RocksIT
    Participant

    Ok I went back & re-read the installation instructions step by step..

    (looks like my .htaccess file was ok, i use hostgator & am pretty sure mod rewrite is enabled)

    I think the problem is my includes/functions/html_output.php

    ok the install instructions state:

    b) Locate the following code
    if ( (SEARCH_ENGINE_FRIENDLY_URLS == ‘true’) && ($search_engine_safe == true) ) {

    and right above it add:

    //-MS- SEO-G Added
    if( $connection == ‘NONSSL’ || SEO_PROCESS_SSL == ‘true’ )
    $link = $g_seo_url->get_seo_url($link, $separator);
    //-MS- SEO-G Added EOM

    However i don’t have that at all in my html_output.php 1 I’m using Standard version
    CRE Loaded v 6.2[10.1]

    so i originally tried adding the following code anyway… hoping the re-write would work..

    but apparently that didn’t work.. how did any of you guys get around this?

    could you maybe share a copy of the correct edited html_output file?

    I’ve posted my original/current file here.. if it helps..

    Thanks for all your help guys!!

  • #107191

    Satish
    Participant

    @rocksit wrote:

    Ok I went back & re-read the installation instructions step by step..

    (looks like my .htaccess file was ok, i use hostgator & am pretty sure mod rewrite is enabled)

    I think the problem is my includes/functions/html_output.php

    ok the install instructions state:

    b) Locate the following code
    if ( (SEARCH_ENGINE_FRIENDLY_URLS == ‘true’) && ($search_engine_safe == true) ) {

    and right above it add:

    //-MS- SEO-G Added
    if( $connection == ‘NONSSL’ || SEO_PROCESS_SSL == ‘true’ )
    $link = $g_seo_url->get_seo_url($link, $separator);
    //-MS- SEO-G Added EOM

    However i don’t have that at all in my html_output.php 1 I’m using Standard version
    CRE Loaded v 6.2[10.1]

    so i originally tried adding the following code anyway… hoping the re-write would work..

    but apparently that didn’t work.. how did any of you guys get around this?

    could you maybe share a copy of the correct edited html_output file?

    I’ve posted my original/current file here.. if it helps..

    Thanks for all your help guys!!

    You need to trace the code flow and make sure code goes thru this function.

    $link = $g_seo_url->get_seo_url($link, $separator);

    Now in this function seo url is generated.

    So chek what gets into the link and seperator when You call this function and what is in link when You exit.

    With in this code there are few conditions.Once we have some idea on this may be we know what the bug is.

    Satish

  • #107192

    tripleG
    Participant

    Is anyone using SEO-G and using imagemagic.php popup images?

    Its definitely broken with that for me. I thought i had the initial install setup and working but my urls never changed on my site. Not sure what i am doing wrong.

    Are there install instructions for cre?

    I couldnt find some code in the html_output.php file
    if ( (SEARCH_ENGINE_FRIENDLY_URLS == ‘true’) && ($search_engine_safe == true) ) {

    So im not sure if i put the code to replace in the correct place.

    Also, it says to “Goto your osC Admin->Configuration->My Store->Use search Engine Safe URLs. Make sure the switch is set to false. ” I did not find that in my admin section.

    My htaccess file is correctly configured as well.

    any help?

  • #107193

    tripleG
    Participant

    whoops, didnt see that last post by Satish. That helped to get it to work for the seo urls.

    My only problem now is my images do not work as I am using imagemagic.php.

    I set an exclude option for that file, but i dont see it working.

  • #107194

    JFenlon
    Participant

    I’ve tried to install it and I’m having the same problem as the original poster. I think it must be related to the catalogincludesfunctionshtml_output.php edit.

    I tried sticking:

    [php]//-MS- SEO-G Added
    if( $connection == ‘NONSSL’ || SEO_PROCESS_SSL == ‘true’ )
    $link = $g_seo_url->get_seo_url($link, $separator);
    //-MS- SEO-G Added EOM[/php]

    Above:

    [php] function tep_href_link($page = ”, $parameters = ”, $connection = ‘NONSSL’, $add_session_id = true, $search_engine_safe = true) {
    global $request_type, $session_started, $SID, $spider_flag;[/php]

    Because that seemed like the most obvious place, with there being no:

    [php] if ( (SEARCH_ENGINE_FRIENDLY_URLS == ‘true’) && ($search_engine_safe == true) ) {[/php]

    But that didn’t seem to help. Has anyone who has got it working got any better ideas? Thanks.

  • #107195

    Satish
    Participant

    @jfenlon wrote:

    I’ve tried to install it and I’m having the same problem as the original poster. I think it must be related to the catalogincludesfunctionshtml_output.php edit.

    I tried sticking:

    [php]//-MS- SEO-G Added
    if( $connection == ‘NONSSL’ || SEO_PROCESS_SSL == ‘true’ )
    $link = $g_seo_url->get_seo_url($link, $separator);
    //-MS- SEO-G Added EOM[/php]

    Above:

    [php] function tep_href_link($page = ”, $parameters = ”, $connection = ‘NONSSL’, $add_session_id = true, $search_engine_safe = true) {
    global $request_type, $session_started, $SID, $spider_flag;[/php]

    Because that seemed like the most obvious place, with there being no:

    [php] if ( (SEARCH_ENGINE_FRIENDLY_URLS == ‘true’) && ($search_engine_safe == true) ) {[/php]

    But that didn’t seem to help. Has anyone who has got it working got any better ideas? Thanks.

    Where did You paste the code.

    Satish

  • #107196

    JFenlon
    Participant

    Above:

    [php] function tep_href_link($page = ”, $parameters = ”, $connection = ‘NONSSL’, $add_session_id = true, $search_engine_safe = true) {
    global $request_type, $session_started, $SID, $spider_flag;[/php]

    Any ideas?

  • #107197

    JFenlon
    Participant

    Anyone have this working? It’d be a shame if I had to uninstall it and look for an alternative solution, from the Admin panel this looks like it’s probably the best SEO URL’s tool for CRE.

    I think the problem is just the html_output.php page, everything else seems to have installed fine.

  • #107198

    tripleG
    Participant

    JFelon, please see my attached html_output file for some reference. I have it working. Also make sure you turn it on it the admin section 😉

  • #107199

    JFenlon
    Participant

    That got the links showing up properly, but when I click them I’m just getting a white page. I guess I need to check things over again and have a read.

    Thanks for the help.

  • #107200

    tripleG
    Participant

    Hmm, sounds like an error somewhere.

    I had a white page showing and it was the server that wouldnt allow errors to be shown on the screen. So i had to do this in the .htaccess file

    # …
    php_value display_errors on
    # …

    comment it out when it is working as you dont want errors on the screen.

  • #107201

    JFenlon
    Participant

    It was my root.php file not set up properly. I’ve fixed it now, but all links are forwarding me to cookie_usage.php.

    [removed] – Click anything on there to see what I mean.

  • #107202

    tripleG
    Participant

    it could be that you didnt set up other files correctly either.
    This im not sure about.

  • #107203

    JFenlon
    Participant

    I guess I’ll have to go through all of the edits again. Thanks for your help.

You must be logged in to reply to this topic.

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close