VVC CAPTCHA Verify Security Code is Blank

Home Forums Community General Support Install & Config VVC CAPTCHA Verify Security Code is Blank

This topic contains 22 replies, has 14 voices, and was last updated by  nexus_rex 7 years, 8 months ago.

  • Author
    Posts
  • #21812

    nexus_rex
    Participant

    Could somebody please help me to get the CAPTCHA Verify Security Code on the Create Account and Contact Us pages working.

    http://www.zootsports.com/online-store/create_account.php

    As you can see, it’s just a blank image. When I right click and View Image, I see this:
    http://www.zootsports.com/online-store/vvc_display.php?vvc=d84a4a94293815e76c11cc961beb8c15

    I have verified that GD is installed.

    Any ideas?

  • #100918

    nexus_rex
    Participant

    I figured this out for anybody else who sees a blank missing image for the Verify Security Image.

    PROBLEM
    GD is installed on my server, but not with Jpeg support. This is what my phpinfo(); shows:


    GD Support enabled
    GD Version bundled (2.0.28 compatible)
    GIF Read Support enabled
    GIF Create Support enabled
    PNG Support enabled
    WBMP Support enabled
    XBM Support enabled


    SOLUTION
    Notice I do have PNG Support.

    1. Open /catalog/includes/functions/visual_verify_code.php
    2. Change line:

                Header("Content-type: image/Jpeg");

    To

                Header("Content-type: image/PNG");

    3. Change line:

                ImageJpeg($im);

    To

                ImagePNG($im);

    That will then create the Verify Security Code image as a PNG instead of a JPG.

  • #100919

    The_Dro
    Participant

    This didn’t work for me. I’m having same issues.

  • #100920

    drm1963
    Participant

    same here but I have JPG support and stil no visible VVC code

    gd
    GD Support enabled
    GD Version bundled (2.0.28 compatible)
    FreeType Support enabled
    FreeType Linkage with freetype
    GIF Read Support enabled
    GIF Create Support enabled
    JPG Support enabled
    PNG Support enabled
    WBMP Support enabled
    XBM Support enabled

  • #100921

    drm1963
    Participant

    OK so NO ONE can explain why the VVC does not work or why it does work and then mysteriously stops working?

    Someone has to have a good answer!

    I will check with my host and see if they can say why it happens and if they tell me anything I will post it here

  • #100922

    allright1688
    Participant

    Hello,

    I met the same problem as above described, have you resolved the problem? I have tried many methods which were searched from forum, but still could not work. Thank you.

    Best regards,
    allright

  • #100923

    Sal
    Keymaster

    in 6.3 if you cannot get VVC to work – you can turn it off. I suggest for anyone wanting to get it working, to setup a dev install in a /dev/ folder (your serial will work on infinite installations under the same domain)

    then enable it on your dev site and continue troubleshooting from there.

    if you get a broken image (use IE for rendering of broken VVC image) you can right click that image, get the full url to it, then browse to the image directly, this will show you the error, which can be a missing class (due to improper FTP attempt) or folder permissions, or missing or improper gd settings.

  • #100924

    allright1688
    Participant

    Hello Sal,

    Thanks a lot for your attention in this problem reported. My online store is using 6.2 B2B Pro.

    As you advised, one full url of the broken image is as following: http://www.mysite.com/vvc_display.php?vvc=3cae … 73deaa1f7b

    Browsing the image directly using the above url, it is still a broken image(red X in the browser page). From the server Error Log (Lunarpages), no error report related to this broken image was found.

    Looking the database via phpMyadmin, there IS a Verify Code corresponding to the above osCsid: 3caec28bdd23655b1709f373deaa1f.

    Especially, as reported by the above drm1963, “…why it does work and then mysteriously stops working?…”. My VVC did work for a few times after the fresh installation, suddenly it stops working.

    Sal, I’ve sent many posts regarding this VVC problem, your kind guidance and help is highly appreciated! thank you!

    Best regards,
    allright

  • #100925

    Sal
    Keymaster

    allright,

    can you expose the url to your site, viewing the direct image should result in a text error message, not just anther broken image.

    you can also PM me if you do not want to post your live url.

  • #100926

    Bazajt
    Participant
  • #100927

    bkopacz
    Participant

    i meanp

    in includes/functions/visual_verify_code.php

    change this

    echo(‘‘);

    to

    echo(‘‘);

    that worked for me …
    after staring at it for days…

    brian

  • #100928

    gusuk
    Participant

    @sal wrote:

    in 6.3 if you cannot get VVC to work – you can turn it off. I suggest for anyone wanting to get it working, to setup a dev install in a /dev/ folder (your serial will work on infinite installations under the same domain)

    then enable it on your dev site and continue troubleshooting from there.

    if you get a broken image (use IE for rendering of broken VVC image) you can right click that image, get the full url to it, then browse to the image directly, this will show you the error, which can be a missing class (due to improper FTP attempt) or folder permissions, or missing or improper gd settings.

    How Do i turn it off? It is not working for me

    http://www.cagefilm.com/usashop/create_account.php

  • #100929

    GregL
    Participant

    I am now having this problem. The link above that says it has the fix is broken.

    I am running 6.2 Pro.

    Any help is appreciated.

  • #100930

    GregL
    Participant

    Can anyone help with this captcha problem? It worked before.

  • #100931

    Sal
    Keymaster

    Please goto tools>server info

    in that phpinfo box is this area

    “configure command”

    this below is from a working site where vvc works

    ‘./configure’ ‘–enable-bcmath’ ‘–enable-calendar’ ‘–enable-dbase’ ‘–enable-exif’ ‘–enable-fastcgi’ ‘–enable-force-cgi-redirect’ ‘–enable-ftp’ ‘–enable-gd-native-ttf’ ‘–enable-libxml’ ‘–enable-magic-quotes’ ‘–enable-mbstring’ ‘–enable-pdo=shared’ ‘–enable-safe-mode’ ‘–enable-soap’ ‘–enable-sockets’ ‘–enable-wddx’ ‘–enable-zend-multibyte’ ‘–enable-zip’ ‘–prefix=/usr/local’ ‘–with-apxs2=/usr/local/apache/bin/apxs’ ‘–with-bz2’ ‘–with-config-file-path=/usr/local/lib’ ‘–with-config-file-scan-dir=/usr/local/lib/php.ini.d’ ‘–with-curl=/opt/curlssl/’ ‘–with-curlwrappers’ ‘–with-freetype-dir=/usr’ ‘–with-gd’ ‘–with-gettext’ ‘–with-imap=/opt/php_with_imap_client/’ ‘–with-imap-ssl=/usr’ ‘–with-jpeg-dir=/usr’ ‘–with-kerberos’ ‘–with-libexpat-dir=/usr’ ‘–with-libxml-dir=/opt/xml2’ ‘–with-libxml-dir=/opt/xml2/’ ‘–with-mcrypt=/opt/libmcrypt/’ ‘–with-mhash=/opt/mhash/’ ‘–with-mime-magic’ ‘–with-mm=/opt/mm/’ ‘–with-mysql=/usr’ ‘–with-mysql-sock=/var/lib/mysql/mysql.sock’ ‘–with-mysqli=/usr/bin/mysql_config’ ‘–with-openssl=/usr’ ‘–with-openssl-dir=/usr’ ‘–with-pdo-mysql=shared’ ‘–with-pdo-sqlite=shared’ ‘–with-png-dir=/usr’ ‘–with-pspell’ ‘–with-sqlite=shared’ ‘–with-tidy=/opt/tidy/’ ‘–with-ttf’ ‘–with-xmlrpc’ ‘–with-xpm-dir=/usr/X11R6’ ‘–with-xsl=/opt/xslt/’ ‘–with-zlib’ ‘–with-zlib-dir=/usr’

    please paste yours

  • #100917

    GregL
    Participant

    Kirk,

    Thanks for your attention.

    ‘./configure’ ‘–localstatedir=/var/hsphere/php’ ‘–prefix=/hsphere/shared/php5’ ‘–with-bz2=shared,/usr’ ‘–enable-ctype’ ‘–enable-bcmath’ ‘–enable-calendar’ ‘–enable-exif’ ‘–enable-dbase’ ‘–enable-fileinfo’ ‘–disable-ldap’ ‘–disable-ncurses’ ‘–enable-pcntl’ ‘–enable-shmop’ ‘–enable-soap’ ‘–enable-sysvmsg’ ‘–enable-sysvsem’ ‘–enable-sysvshm’ ‘–enable-dba’ ‘–enable-ftp’ ‘–enable-zip’ ‘–enable-shared’ ‘–with-gettext=shared,/usr’ ‘–enable-mbstring=all’ ‘–with-gd=shared’ ‘–with-mhash=shared’ ‘–with-mcrypt=shared’ ‘–with-mime_magic=/hsphere/local/config/httpd/magic’ ‘–with-openssl=shared,/usr’ ‘–enable-posix’ ‘–enable-session’ ‘–enable-sockets’ ‘–enable-tokenizer’ ‘–with-xsl=shared,

  • #100932

    GregL
    Participant

    I had my host check on the problem with vvc. They did a test with the visual_verify_code.php by adding:
    $code=”3test”;
    vvcode_render_code($code);
    echo $code;

    at the end. When browser is directed to that file it produces the vvc graphic just fine.

    When I try the same code addition to vvc_display.php and point my browser to it just displays the filename like this: http://shopping.thebackstores.com/catalog/vvc_display.php

    Sure would like to get a handle on what is wrong with this. Not being an expert it seems that the visual_verify_code.php routine is not being found by the vvc_diplay.php routine.

  • #100933

    eldayforum
    Participant

    how about on the case of the captcha displays fine but when you typed the exact same values on the provided textbox, it will say that you have entered the incorrect codes…
    what do you think is the problem on that?

    Directors Insolvency

  • #100934

    GregL
    Participant

    That sounds like a db problem. I would look there first.

  • #100935

    RegDCP
    Moderator

    I just hit this problems with a couple of sites.
    As I have several CRE sites on my server it was easy to determine that the problems were with individual installs and not globally as the GD library was working and *most sites displayed the code.

    To find the problem I opened the page where the captcha image should be and right clicked on the broken x and selected prop[erties.
    This gave me a link – /vvc_display.php?vvc=a6136ac25437730ff0b67b043435 (link changed – use your own), which I plugged into my browser to see that I was getting a headers sent warning from my includes/languages/english.php

    Now while headers sent error is usually caused by unwanted white space I have learned that my brand new MS Expressions web authoring program was automagically saving pages as UTF format instead of the old ASCII.

    To fix the errors I opened the indicated pages in Expressions and saved changed the page settings to US ASCII. I then closed the page and reopened it as html and removed the head and page type statement that was just written.

    VVD works properly now.

  • #100936

    angad
    Participant

    I was having the same issue, but following solution worked for me. The page was sending something else before the page which was causing this issue. In mycase it was just showing page URL instead of an image, so clearing the page/browser cache worked for me. Please try the following code to resolve this issue and also make sure your $code variable is not empty.

    Goto: public_html/vvc_display.php
    find code: vvcode_render_code($code);
    add just above it:while (@ob_end_clean());

    So, last three lines of the code look like following.

    while (@ob_end_clean());
    vvcode_render_code($code);
    ?>

    Please provide an acknowledgment here whether this solution worked for you or not.

    Thanks,
    Angad

  • #100937

    ongjoh
    Participant

    Hi,

    My issue is that the VVC is visible when I am in the English Language. When I switch to the Chinese Language, the image becomes a X

    Any idea?

  • #100938

    Anonymous

    Thanks Angad your fix worked for me and I’ve been searching for quite a while.

    I have several CRE sites running on different servers and the VVC code has always just worked. On my latest site hosted with hostgator is didn’t work.

    I’m using B2B 6.3.2.

    I just changed the last lines of vvc_display.php to:

     // CSL Fix to VVC not displaying problem
    // http://creloaded.org/forum/23/21243.html?start=15
    // Thanks Angad - next line added
    while (@ob_end_clean());
    vvcode_render_code($code);
    ?>

    And it works!

You must be logged in to reply to this topic.

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close