Requirements

LoadedCommerce can be installed on any web server with PHP installed which has access to a MySQL database server. This includes shared servers, dedicated servers, and local installations running on Linux, Unix, BSD, Mac OS X, and Microsoft Windows operating systems.

Web Server

The web server must support PHP either as a module or allow execution of CGI scripts. For performance reasons FastCGI is recommended over CGI.

PHP

The minimum PHP version required is v4.1. It is recommended to use the latest PHP 5 version on the web server. Note that some functionality such as Automatic Updates requires PHP 5.3 or later.

The following PHP options are recommended, but not mandatory, to be set in the php.ini configuration file:

register_globals Off
magic_quotes_gpc Off
file_uploads On
session_auto_start Off
session_use_trans_id Off

The following PHP extensions are mandatory:

MySQL MySQL database extension for PHP 4.
MySQLi MySQL Improved database extension for PHP 5

The following PHP extensions are recommended:

GD Image processing module.
cURL Network communication library.
OpenSSL Encryption library.

MySQL Database Server

The minimum MySQL version required is v3.23. It is recommended to use the latest MySQL 4 or MySQL 5 version on the database server.

The following MySQL storage engines are supported:

MyISAM Default Storage Engine.
InnoDB Transaction-safe storage engine.*

* InnoDB storage engines do not support fulltext index searching

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close